Sony VAIO P Windows 7 clean install guide

Sony VAIO laptops come installed with lots of bloatware and, given the VAIO P series’ low power CPU, this really ruins it. Out of the box running Vista my P11Z was barely usable. Here’s how to clean install Windows 7 and the minimal amount of Sony software, which results in a striking improvement.

I wrote this up for the forum at Pocketables.net (the main forum it seems for the VAIO P), but I’ll post it here too. I once had a bad experience with sudden forum deletion – In 2003 I wrote an IPSec VPN guide on the official Netgear forums and one day when I needed it I discovered that they’d relaunched the forums, and deleted all the old content! Needless to say I didn’t have my own copy and web.archive.org didn’t have it either…

Back to the VAIO:
Sony VAIO P

Before you start, use the GlobeTrotter Connect software to check the firmware version of your Option GTM382 HSDPA + GPS card. If it’s lower than 2.9.5.0, this update will vastly improve your GPS signal strength. Mine went from not working at all, even outside, to being able to get a fix in VisualGPS indoors. You can search for the firmware file by name but it’s not legitimately available – Sony does not distribute the update, despite Option’s official documentation stating that the version they shipped with is non-working. More details in this thread.

You can use the Sony Windows 7 Upgrade media to carry out a clean install.

Using another PC with a DVD drive, make a bootable 4GB USB stick from your Windows 7 upgrade kit DVD 2 using these instructions.

Boot from USB (enable ‘Boot from external’ in the BIOS), select Custom once Windows Setup launches, completely wipe the drive (assuming you no longer care about the Vista recovery partition) and continue. When the Vaio reboots remove the USB stick or it will boot from it and re-launch Setup. Do not enter a product key and make sure you uncheck the Activate Windows Online Automatically option. Next, install Service Pack 1, then once that is done you can remove the uninstall files from the disk to save space. Disabling hibernation will also save you 2GB of disk space:
dism /online /cleanup-image /spsuperseded
powercfg -h off

Now that Windows is fully installed, make sure you have no Windows Updates with pending restarts, and go to right-click on Computer in the Start Menu and select Properties. Scroll down and Activate, using the product key from the DVD case. It took a good few minutes but worked for me.

Use Windows Update and in the Optional Updates select the two Sony devices (Sony Firmware Extension Parser Device, and Sony Programmable I/O Control Device), and the updated Atheros Wifi drivers. Install. These are the same versions that are on the Sony driver site.

Install the most recent Intel GMA 500 driver from Intel.com > Downloads > Graphics > Laptop graphics controllers > Graphics Media Accelerator 500 > Windows 7

Now go to the Sony Vaio support page for your model and download and install the following Windows 7 drivers, in order:

  • Sony Shared Library – restart, as a precaution
  • Setting Utility
  • VAIO Event Service (needed for volume and brightness keys)
  • VAIO Control Center
  • VAIO Smart Network – (needed to enable the Option card) – restart

When Windows reloads, the Option WWAN card will be detected and it will fail to find drivers. Download the Windows 7 Mobile Broadband mode driver package only (not the Globetrotter Connect software) for a P11Z from here. No IMEI is required for this download. Drivers for other Option WWAN cards are available in the Embedded Devices section at the bottom of this page. Windows 7 has a built-in framework for managing mobile broadband connections so we can avoid Option’s terrible GlobeTrotter bloatware, which uses 20% of a 1.33GHz CPU even when idle. In Device Manager, find the non-installed device and select Update Driver, pointing it at the files you just downloaded and unzipped. On the next reboot I think, you’ll have a whole load more unidentified devices. These are all the parts of the Option card like the GPS serial ports, the Network device etc. For each one repeat the same steps as you did for the parent device, pointing it at the downloaded driver folder. Now, when you insert a SIM card you will notice that Windows 7 will offer a new network in the wireless icon in the System Tray which will have your cellular network carrier as its name. All you need is the APN name and username/password – nice and simple. If you want to have the WWAN card disabled by default as Windows starts (to save power) you will need to use the full Smart Network UI to disable both the GPS and the WWAN. This wasn’t clear and took me some considerable time to figure out.

Install the HDD Protection Driver from the Originally Installed downloads section on the Sony site. This adds some options to the VAIO Control Center, and I think is a useful addition for a mobile PC.

Install the Chipset driver, also from Originally Installed too. These Intel chipset drivers aren’t really drivers – they just title up certain devices in the Device Manager to have their correct names. So PCI-PCI Host Device (or whatever) becomes Intel(R) SCH Family PCI Express Root Port 1 – 8110. I had a hunt around for more up to date ones for Poulsbo systems but there are none, not even with Dell, so don’t worry that it’s a Vista driver. On the Sony US support site they’re more organized and both the HDD Protection driver and Chipset drivers are correctly listed in the Windows 7 section (same exact versions).

Do not install the Battery Check. It’s a driver that checks to make sure you are not using a third party battery and wastes system resources. As I also found out, it lacks an uninstall option and it took me a while to remove it from my system last time around.

From the Windows 7 section of the Sony site install Instant Mode, the RealTek audio driver, and the Alps stick pointer driver. Although scrolling by holding the middle button does already work without the Alps driver, it is still useful to install because it offers sensitivity options, and tap-to-click functionality which I find very worthwhile. If you’re using them a lot the button clicks can get tedious and loud. The RealTek audio driver offers one particularly useful feature over the stock Windows audio driver – the ability to use Dynamic Range Compression to amplify very quiet audio, which can often be a problem when watching movies using the speakers. To enable this when you need it, open Sound in Control Panel. In the Playback tab select Speaker/HP and click Properties. In the Enhancements tab scroll down and you’ll find Loudness Equalization.

If you don’t use the LAN connection, open Device Manager and disable Intel(R) SCH Family PCI Express Root Port 1 – 8110 in System Devices. This is how Sony shipped the factory-installed Vista build, so I guess it uses less power that way.

For lean software I recommend:

  • Chromium web browser (open source Google Chrome – no behaviour profiling)
  • Sumatra PDF instead of an increasingly malware-vulnerable/targeted Adobe Reader
  • This fantastic sidebar gadget which shows CPU temp and SpeedStep clockspeed – very useful for a Vaio P user

Additional guides

DXVA H.264 playback on Intel GMA 500 with subtitles (Windows 7)
DXVA VC-1 playback on Intel GMA 500

About these ads

39 thoughts on “Sony VAIO P Windows 7 clean install guide

  1. soundgeek

    I’m planning to upgrade my P11Z from vista to Win7, so this is just the guide I need. I have a generic USB-DVD drive for it though, so maybe I can install direct from my upgrade DVD and skip the bootable flash drive?
    Is it possible to keep the Instant Mode (Linux) system? Is that in the Recovery partition?

    Reply
  2. patters Post author

    Yes, you can skip that step. The Instant Mode is something you can install again once you’ve reinstalled Windows. It’s bundle of files that get installed to the root of the C: drive. You’ll see Instant Mode listed on the P11Z download page.

    Reply
    1. soundgeek

      Thanks for the advice. I’m still going through the process. The only problems I’ve hit are:

      1. after I’d flashed the GTM382W with ver 2.9.5, I couldn’t get the GPS to switch on under Vista.

      2. after running the Win7Pro upgrade disk, when I tried to install the GMA500 driver 5.0.0.2026, I got a “Not validated for your computer” error. The same happened with version 5.0.0.2024 (the previous version on the Intel site) so I’ve skipped that and gone on to the Sony software. Does it matter that I have skipped that? I’m not sure how to correct the problem. Maybe there’s a version on the Sony site?

      Reply
      1. soundgeek

        ps
        3. When I selected Win7 Optional Updates, I found AAAAAR928x Wireless Network ok, but the only other optional was KB976422, some sort of security update?, not Extension Parser or Programmable I/O.

        4. I downloaded from Option the 5.1.36.0 driver installer for Win7, but I can’t see any devices without drivers. All the devices I can see claim to be working. Scanning for hardware changes in Device Manager doesn’t throw up any devices in need of attention.

        So all good fun! :)

  3. patters Post author

    The GPS seems to sometimes get itself in a state where the Smart Network button doesn’t turn it on. I had that on Windows 7 the first time around, but I’d been messing around adding and removing all sorts of different versions of the various Sony components. You can get around it by using the tool called GPSonoff.exe (linked to in the threads about GPS on pocketables.net forum). However, I found that after a clean install of Windows 7 it has been fine ever since.
    I didn’t have any issue with the Intel GMA installer and I also have a P11Z. Had you installed an earlier version before that perhaps? Failing that you should be able to open Device Manager, find the graphics card, select Update driver and point it at the folder you extracted the Intel GMA zip file into. You don’t have to use the setup.exe.

    Reply
    1. patters Post author

      Windows Update can be a bit fickle when it comes to showing you available hardware updates. Those two device drivers can be found at the Sony download site. It is critical that you install all the components in that order though. The Option card isn’t switched on until all that other stuff is in place and Smart Network is installed.

      Reply
  4. soundgeek

    Using Device Manager, I attempted to update the GMA500 drivers. It said it already had the latest driver (8.?.?.? 2009 – I failed to write it down). I uninstalled with delete & re-installed the latest. It now says: 8.04.10.2026 11-Jun-2010.

    I can’t find the Sony Firmware Extension Parser Device driver on the Sony european support site. I’ve found it for another model on the US site. It is flagged for US, Canada etc, but not europe. (I purchased the P11ZW in the UK). P11ZW support is redirected to Europe.

    Current installed versions are:
    FEPD 8.0.1.1 21-May-2010
    PI/OCD same version.
    I’ve no idea where it got these from. I wonder if they are up-to-date?

    Will I have to start all over again?

    Reply
    1. patters Post author

      As long as those two Sony devices are installed (i.e. they’re not showing as question marks in Device Manager) then you should be fine. I don’t have my VAIO to hand but that version number sounds right from what I can recall. It must have picked it up from Windows Update after all.

      Reply
      1. soundgeek

        It looks like it works so far! :)

        I tried to download drivers from Option.com but got an installer (for Windows 7 only) so rather than pick drivers via Device Manager, I ran the installer and it did it’s stuff.

        GPS with VisualGPS works a treat!

        My only problem at this stage is that I haven’t a clue what Username & password to put in the ISP box. I use the O2 sim from my Nokia/symbian phone. I suppose O2 sent me an automatic settings txt for the Nokia which loaded them in the phone somewhere. The Globetrotter software figured it out automatically under Vista.

        If I can test the WLAN then I’ll try finishing off the upgrade & then back it all up. Maybe I got away with not updating things quite in order?! Better not speak too soon…

    2. ric

      To install the intel GMA 500 driver version 5.0.0.2026 (in intel site), you must unzip the file and update the graphics driver, making the windows search the unziped folder.
      It seems that the intel gma 500 driver 5.0.0.2026 is newer than driver version 8.14.10.2024 avaiable in the sony site, but I did install the intel driver and lost the option of resolution of 1280×600 (that’s nice feature, 1600×768 is damn small and hard to see!).
      Does anyone know how to solve this problem, how to put the latest intel driver with the resolution of 1280×600? Does make any difference change the driver? I must simply maintain the driver version 08.14.10.2024?

      Reply
  5. patters Post author

    If it’s O2, the details are normally username:vertigo password:password I think. Be sure that installer didn’t load on that GlobeTrotter Connect thing. That will really slow down your machine.

    Reply
    1. soundgeek

      Thanks for the prompt replies patters.

      I’m confused about WWAN. When I go into VAIO Smart Network & click Connection Utility, it says Please install the Wireless WAN connection utility. Although WWAN is set to Enabled, WWAN won’t turn on in the Smart Network window.

      Also I can’t find the ISP box any more, so I can’t try those details you gave me.

      I can’t see the Globetrotter software anywhere, so I think I have not installed it.

      Reply
    2. soundgeek

      WWAN – I still haven’t got to the bottom of this.

      A couple of reboots later it found the sim card and asked for the sim unlock code. Then it asked for APN, username, password. I tried your suggestions and it failed to connect.

      A bit of research suggests I should have used “payandgo”. Unfortunately I haven’t seen this dialogue box since. It is as if the WWAN modem is physically switched off.

      The Vaio boots up in 45s. iPlayer looks good via WiFi. But WWAN worked fine with Vista/Globetrotter and currently I’m stuck.

      Reply
      1. patters Post author

        If you’re using the proper Windows 7 driver (which from the sounds of it you are) you should see in the bit on the task bar where wireless networks are listed it should have an entry called O2 – UK. Click on that and you’ll be asked for your APN details. Smart Network is a pretty buggy unfortunately so it often shows the wrong status light for WWAN. In general, click on the GPS icon to turn on the WWAN card & GPS. Click on the WWAN card icon to turn them both off.

  6. soundgeek

    Ah, I noticed that about Smart Network. The small window indicators can be different to the large window & GPS turns off when I turn off WWAN.

    No I don’t see an O2 icon in the task bar. Also a lot of the time I don’t see the Globetrotter device in the Modem category in Device Manager….

    Today I can see the O2 connection & it prompted for the sim unlock code. Then told me there is no signal – unlikely. Hovering over the double-arrow icon, it tells me “WWAN enable”.

    I’ll check ot the device drivers & post those.

    Reply
  7. soundgeek

    Here’s the current state of drivers. I have an entry under Modems today.

    Display Adaptor
    GMA500 11-Jun-2010 8.14.10.2026

    Modems
    Globetrotter MO40x – Modem interface

    Network Adaptors
    Atheros AR928X Wireless Network Adapter 30-Oct-2009 8.0.0.238
    Globetrotter Mo040x – Network Interface #2 15-Dec-2009 5.1.36.0
    Marvell Yukon 88E8057 PCI-E Gigabit Ethernet 23-Feb-2009 11.0.5.3
    Microsoft Virtual WiFi Miniport Adaptoer 21-Jun-2006 6.1.7600.16385

    Ports
    Globetrotter MO40x – Application 2 Interface (COM7) 15-Dec-2009 5.1.36.0
    Control Interface (COM6)
    Diagnostics Interface (COM4)
    GPS Control Interface (COM3)
    GPS Data Interface (COM5)

    Smart Card Readers
    Globetrotter MO40x – Smart Card Interface 15-Dec-2009 5.1.36.0

    Reply
  8. soundgeek

    I rebooted (again!) with the SIM in. GPS was on, WLAN & LAN both off. WWAN came on automatically.

    I left-clicked the little signal-strength indicator icon. It told me Service Provider:O2; Network type:GSM, along with SIM ICC ID and IMEI. Right-click/Properties showed:
    profile: payanddgo.o2.co.uk
    User name: payandgo
    Password:

    It found all this automatically! Why? I haven’t changed any settings. Internet access works! We’ll see how reliable this is.

    I wonder what the win7 Activation Utility is for WWAN so that I can link to it in Smart Network?

    I hope the driver versions above are useful to others.

    Many thanks for a brilliant guide patters :)

    Reply
    1. patters Post author

      Glad you got everything working. I noticed last month while on holiday that the WWAN card’s behaviour is erratic after sleep mode, so you probably should reboot whenever you want to use it.

      Reply
  9. Tiago

    PERFECT!!

    THANKS VERY MUCH FOR THIS GUIDE

    I WAS LOOSING MY HEAD WHEN I DID A CLEAN INSTALL OF 7 DUE THE LACK OF CORRECT AND ORDER DRIVERS

    PERFECT ON MY VAIOP 21Z

    CHEERS FROM PORTUGAL, KEEP THE GOOD WORK

    Reply
  10. Luca

    Hi, thanks for this guide, but it still doesn’t work to me.
    I have bought a used VGN-P80H in Japan. The OS was japanese Vista, I cannot read it, so I formatted it and made a clean installation of italian W7. Function keys and GPS and WWAN didn’t worked. Then I did a second clean installation following your guide, but they still do not work.

    Function keys: I can control volume but there’s no displaying; brightness keys don’t work.

    Option card: no sign of it in the Device Manager. In the Smart Network panel if I try to turn WLAN on, it tells “Turn the hardware switch on e try again”; do not understand the message, but I can connect (W7 connected it immediately but it seems this connection is not hold by Smart Network). By the way, when there was the japanese Vista on, in this panel there 4 items for LAN, WLAN, WWAN and Bluetooth. Now it controls only WLAN (with the previous message) and LAN (it cannot be selected, maybe I need VGPDA10).

    GPS: no way. Actually I did not understand how to use it.

    Any suggestion will be appretiated.
    Thanks in advance
    Luca

    Reply
    1. patters Post author

      Hi Luca, I believe that there are slight hardware differences with the Japanese versions which probably explain the issues you are facing. I think your best option is to start a thread over at the pocketables.net forum since I seem to remember that there are a few people who have successfully reinstalled Japanese machines.

      Reply
  11. Christian Solitario

    Hi, I bought a Vaio P91 in Japan. This computer had a Windows Vista Japanes Version.
    Today I formatted my vaio with you Guide. All componets are Right. Also GPS.

    But, Some times WWAN it to difficul for Turn ON. And I don`t know how Conect with GSM.
    After I used GlobeTrotter, Now I used a Windows 7 certified driver package.

    Could you please help me?

    Any suggestion will be appretiated.

    Christian Solitario

    Reply
    1. patters Post author

      Hi, I’m afraid I really have no idea about the Japanese models. From what I understand there are hardware differences so you’re probably best asking on the pocketables.net forums. There are users on there who imported Japanese units.

      Reply
  12. Pingback: [Sammelthread] Sony Vaio VGN-P11Z - Seite 3 - Forum de Luxx

  13. ArchiMark

    “Do not install the Battery Check. It’s a driver that checks to make sure you are not using a third party battery and wastes system resources. As I also found out, it lacks an uninstall option and it took me a while to remove it from my system last time around.”

    Wish I’d found your site before doing fresh Win7 install…. ;)

    Anyway, I installed Battery Check when installing Notebook Utilities on my gen II Vaio P….now, I’m getting constant error message, that forces you to hibernate Vaio in order to check if battery insertion is OK….

    As you say, it’s not obvious how to uninstall. Any recollection of how to uninstall it?

    Thanks for any advice!

    Reply
    1. patters Post author

      Sorry, it was too long ago for me to remember. There was a service that needed removing and a bunch of reg keys. The problem was that the name wasn’t obvious so it was hard to be sure I wasn’t removing some other Sony component. I had to do it by trial and error. Make sure you export any bits of the registry you tamper first, so you can put them back if it breaks something.

      Reply
      1. ArchiMark

        Thanks for your reply, in meantime I found the solution.

        All you need to do to is disable ‘ISBMgr.exe’ in ‘msconfig’….that’s it!

  14. Dave

    I’ve got a UK P11Z and my WWAN is not working properly I just keep getting the Operation Timed Out when I click on connect even with the correct APN settings, this happens on T-Mobile and 3 so I assume its a problem with the software, it all worked fine under Vista. I downloaded the drivers from the option web site I’ve removed and re-installed the drivers and its still the same.

    Reply
  15. Dave

    Ok I’ve done a fresh install following your above instructions and its still not working I was hoping it was something i’d done. I didnt have any unknown devices on re-boot it found and setup the option wwan stuff itself. Still get timed out error.

    Reply
  16. abbas

    hi . i got a vgn-tt11wn model and the issue i am facing is the wwan option . i cant connect it .. smart network gets installed and it asks for wwan connection utility which i cant download from anywhere ,, also as someone stated that u need a broadband driver which also i couldnt find to download . so m stuck ! also i would really like to know if a laptop that was bought in uk would the wwan services work in china ? like if i get a local chinese sim card ! is it country restricted ?

    thanks a million

    Reply
  17. John Hudson

    Hi there, excellent threat! I’ve been putting off upgrading my VGN-P19VN for ages(if it aint broke…), but this is an excellent step by step guide.

    The only thing I’ve stumbled on so far is the HDD Protection Drivers, I’ve found the files, but they are just that files rather than any kind of install kit. I’m not sure if I’m missing something as I’ve had to do the fresh install from a MAPS version of Window 7, but is there any specific trick to getting the HDD Protection Drivers installed? I’ve even installed Vaio Update, but that doesnt see anything relating to HDD protection.

    Reply
    1. patters Post author

      Hi, from memory I think the only sign the HDD protection option is installed is whether or not it shows as an option within the VAIO Control Center. I thought it was just a normal executable installer.

      Reply
      1. John Hudson

        That makes sense. Both Windows and Vaio Update and the Control Centre dont seem to have any reference for it. Everything seems to work otherwise.

        The only other driver that now seems missing from the ‘net is the ALPS Stick Pointer, nice to have, but no biggy.

        Thanks again for the thread, its made life much easier

  18. ksb1972

    Thank you so much for taking the time to create this guide. I was replacing Vista with Win 7 on a Sony VGN-BZ11XN for someone who is very careless with his laptop (I’ve seen the HDD shock protection kick in a few times while he manhandles it!), but couldn’t seem to get the anti-shock driver working after installing Win 7.

    Sony’s website is carp in this respect, they don’t seem to have much in the way of Win7 specific stuff for this machine.

    I followed the installation order specified above (quite how you worked out what goes first without any official docs (don’t like Sony for that) and it now appears to be working. It certainly shows up in the VAIO Control Centre now along with the sensitivity options. But can’t be sure it’s really working! I tried gingerly waving the laptop around, but didn’t see any messages to say it had kicked in. Oh well, guess I’m just too scared to get too brutal with it! Time will tell if it’s actually working I guess. I certainly hope so.

    Thanks again. You’re a star!!!

    Reply
  19. E-Chan42

    I’ve been trying to get decent speeds on my VGN-p21z using windows 8.1 but I’m far from it. whenever I scroll on any web browser (I’ve disabled hardware acceleration) DWM spikes up to more than 80% CPU usage and I can only think that the driver for the GMA500 I’m using is inadequate. Currently running 8.14.10.2030. Even microsoft’s standard driver works better.

    What can I do to fix this?
    Thanks

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s